Any linux/unix or Windows web hosting account with the following software/services enabled.
  • PHP 5.6 or higher - including PHP 7.0.
  • MySQL 5 or higher.
  • Extension: PDO
  • Extension: ionCube
  • Extension: mcrypt
  • cURL enabled. Use for product updates, video training, some cart integrations, etc.
  • GD Library w/ TTF (True Type Fonts) enabled. Used for security (captcha) image on affiliate signup form.

Owned Editions Only - Wordpress Based Hosting Accounts
Installation of our owned edition into any "Wordpress Based" hosting account will almost always cause issues. Some examples of this type of hosting would be WP Engine or WordPress Hosting by GoDaddy or WordPress Hosting by Site Ground, etc. Hosting with these WP based services has offered numerous issues over the past. In some cases ionCube isn't enabled and customers are told it can't be enabled. Often times these hosting accounts have caching tools and other services enabled that don't play well with standard PHP functionality such as PHP sessions (required for secure account login). Many only allow 1 MySQL database. We have also seen issues with Mcrypt not being enabled as well. In short, WP based hosting accounts are not supported as we've only seen a handful of successful installs on them.

A regular/traditional hosting account is needed for use with the owned edition of iDevAffiliate.

Owned Editions Only - Yahoo Web Hosting Notes
The Yahoo hosting service does not have ionCube enabled, nor do they have run-time loaders enabled. It only affects people who want to host iDevAffiliate with their Yahoo Hosting account.

This does not affect the use of Yahoo Stores with iDevAffiliate.